Site Update: WordPress 5.8

Background: This is an advisory to our members, that going forward, you should use a modern browser to view our site. In order to maintain web accessibility standards (Section 508) and ensure the security of information on our site; we will be updating the WordPress version that the site runs on. What do I need … Read more